Project

General

Profile

Bug #1457

mclinker build error

Added by Marc Marí over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
toolchain
Target version:
Start date:
07/29/2016
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
Host OS:
Linux
Toolchain:
clang-3.5
Android version:
CrystaX Version:

Description

When compiling the mclinker for llvm-3.5, ScriptScanner.cc (generated previously with flex) fails to compile. This doesn't happen with llvm-3.6.

I have flex version 2.6.0 on a Fedora 23 with Linux 4.5.7

I solved this error by copying /usr/include/FlexLexer.h to crystax/toolchain/mclinker/include/mcld/Script/FlexLexer.h

I attach the full build log.

(From [[https://groups.google.com/forum/#!topic/crystax-ndk/O62nc9Kaz5w]])


Files

build_clang.log build_clang.log 307 KB Marc Marí, 07/29/2016 01:49 PM

History

#1

Updated by Dmitry Moskalchuk over 3 years ago

  • Category set to toolchain
  • Assignee set to Dmitry Moskalchuk
  • Target version set to 11.0.0
#2

Updated by Dmitry Moskalchuk over 3 years ago

Hmm... I don't see build.log attached. Do you miss one? Please attach it again. Please note that only .zip/gz/bz2 are accepted as an attachments.

#3

Updated by Marc Marí over 3 years ago

Full build.log in bz2 is 2.7MB, and I get "Request entity too large" when trying to upload. I didn't see it before.

I upload the build.log only for the full llvm-3.5 (including the mclinker). Hope it is enough.

#4

Updated by Dmitry Moskalchuk over 3 years ago

  • Assignee changed from Dmitry Moskalchuk to Alexander Zhukov
#5

Updated by Alexander Zhukov over 3 years ago

  • Status changed from Open to Waiting for feedback

It seems to me that you are using an outdated NDK ;)
Crystax NDK 10.3.1 (latest release) does not support neither llvm-3.5 nor mclinker.

As far as I remember mclinker was supposed to be built by only one llvm compiler and then it could be used by all llvm version.

I do not know why Google started to use mclinker and why stopped to use it (r11c do not include mclinker).

If you do know some serious reasons why mclinker should be included into NDK, please, do not hesitate to share your knowledge with us :)

#6

Updated by Marc Marí over 3 years ago

Then, the issue is related to this other bug: https://tracker.crystax.net/issues/1443.

I used the script directly, and I didn't check which version I was using.

Thanks!

#7

Updated by Dmitry Moskalchuk over 3 years ago

  • Status changed from Waiting for feedback to Closed
  • % Done changed from 0 to 100

Closing this ticket since #1443 is closed now. If something goes wrong, please feel free to file new ticket or reopen this one.

Also available in: Atom PDF