Project

General

Profile

Bug #1405

Make standalone toolchain is broken for gcc (r859)

Added by Andrey Alekseenko about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
standalone
Target version:
Start date:
05/31/2016
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
Host OS:
Linux
Toolchain:
gcc-4.9, gcc-5, gcc-6
Android version:
CrystaX Version:

Description

~/crystax-ndk-10.3.1-r859/build/tools/make-standalone-toolchain.sh --platform=android-16 --arch=armHOST_OS=linux
HOST_EXE=
HOST_ARCH=x86_64
HOST_TAG=linux-x86_64
HOST_NUM_CPUS=8
BUILD_NUM_CPUS=16
Auto-config: --toolchain=arm-linux-androideabi-4.9
Copying prebuilt binaries...
Copying sysroot headers and libraries...
cp: cannot stat '/home/andrey/crystax-ndk-10.3.1-r859//libs/armeabi/*': No such file or directory
Copying crystax headers and libraries...
ERROR: Cant' copy from non-directory: /home/andrey/crystax-ndk-10.3.1-r859//libs/armeabi

History

#1 Updated by Alexander Zhukov about 3 years ago

  • Status changed from Open to Waiting for feedback

Andrey Alekseenko wrote:

~/crystax-ndk-10.3.1-r859/build/tools/make-standalone-toolchain.sh --platform=android-16 --arch=armHOST_OS=linux

Could you please try ~/crystax-ndk-10.3.1-r859/build/instruments/make-standalone-toolchain.sh ?
All our build scripts are in build/instruments directory now.

#2 Updated by Dmitry Moskalchuk about 3 years ago

  • Category set to standalone
  • Assignee set to Alexander Zhukov

#3 Updated by Andrey Alekseenko about 3 years ago

I've checked,
from build/instruments it works as intended.
What about old scripts in build/tools? Will they be kept or symlinked to new location for compatibility?

#4 Updated by Dmitry Moskalchuk about 3 years ago

Andrey Alekseenko wrote:

What about old scripts in build/tools? Will they be kept or symlinked to new location for compatibility?

Yes, we'll move make-standalone-toolchain.sh back to the $NDK/build/tools/ folder. This is temporary re-structurization, caused by merging with Google's NDK source tree. We've moved all our scripts to the $NDK/build/instruments since there was too big amount of conflicts and we don't want to solve them in destructive way. In fact, we just don't need many of that scripts in place anymore, but Google's developers do many changes in NDK build process last time, so we've decided to move all our scripts to the $NDK/build/instruments temporarily, keeping all Google's changes in $NDK/build/tools. We're going to make cleanup there, completely getting rid of $NDK/build/instruments, and removing most of the $NDK/build/tools scripts.

Specifically make-standalone-toolchain.sh will be moved back to the $NDK/build/tools soon, since it's part of the public NDK interface, provided for running by NDK users, so this will not break compatibility.

#5 Updated by Andrey Alekseenko about 3 years ago

Thank you for detailed expanation! Looking forward to v11.0. Good luck!

#6 Updated by Alexander Zhukov about 3 years ago

  • Status changed from Waiting for feedback to Done
  • % Done changed from 0 to 100

Fixed in [ndk] 99b998528c5dc153a4b40840f0ac26897d1951b2

#7 Updated by Dmitry Moskalchuk about 3 years ago

  • Status changed from Done to Closed

Fixed in build #865

Also available in: Atom PDF