Project

General

Profile

Bug #1380

SIGSEGV in libcrystax.so - lrint

Added by Chengyuan Lin about 3 years ago. Updated about 3 years ago.

Status:
Duplicated
Priority:
Normal
Category:
libcrystax
Target version:
Start date:
04/29/2016
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
arm
Host OS:
Windows
Toolchain:
clang-3.7
Android version:
4.1 (android-16), 4.3 (android-18)
CrystaX Version:

Description

I know this is similar with one previous report Bug #1369, however it is a different function lrint vs. lrintf.

I met this problem when I was trying to compile OpenCV, it compiles well but when library is loaded (from Java), in the initialization of some static variables, function lrint is called and program crashes. The tricky thing here is for OpenCV, this happens when the library is getting loaded rather than normal function call, leaving it hard to locate the actual problem.

Hope you can fix this bug soon, also hope this post will help whoever want to build OpenCV using Crystax (if any).


Related issues

Has duplicate CrystaX NDK - Bug #1369: SIGSEGV in libcrystax.so - lrintfClosed2016-04-21

History

#1 Updated by Dmitry Moskalchuk about 3 years ago

  • Subject changed from SIGSEGV in libsrystax.so - lrint to SIGSEGV in libcrystax.so - lrint
  • Category set to libcrystax
  • Assignee set to Dmitry Moskalchuk

#2 Updated by Dmitry Moskalchuk about 3 years ago

  • Has duplicate Bug #1369: SIGSEGV in libcrystax.so - lrintf added

#3 Updated by Dmitry Moskalchuk about 3 years ago

  • Status changed from Open to Duplicated
  • % Done changed from 0 to 100

This is actually the same bug as #1369 – i.e. crash is caused by call of fegetenv – so close it as "duplicate".

Also available in: Atom PDF