Project

General

Profile

Bug #910

'errors_handling_test' failed because it can't find some files on device

Added by Dmitry Moskalchuk over 4 years ago. Updated over 4 years ago.

Status:
Invalid
Priority:
High
Category:
-
Target version:
-
Start date:
03/20/2015
Due date:
% Done:

0%

Estimated time:
CPU Architecture:
Host OS:
Toolchain:
Android version:
CrystaX Version:

Description

http://www.boost.org/development/tests/develop/developer/test.html

Obviously, adbrunner don't copy some files (required for this test) on device before running test.

Running 1 test case...
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!
../libs/test/test/errors_handling_test.cpp(190): error: in "test_errors_handling": check test_output.match_pattern() has failed. Pattern file can't be opened!

*** 54 failures detected in test module "Master Test Suite"

History

#1

Updated by Dmitry Moskalchuk over 4 years ago

  • Status changed from Open to Invalid

According to the message from Niklas Angare, this is actually bug of @errors_handling_test@. Here is his explanation:

"Dmitry Moskalchuk" dm@crystax.net wrote:

CrystaX runners are cross-platform runners, which differs from other runners significantly. All tests are compiled on
Linux with help of CrystaX NDK and then uploaded to Android device and executed there. To make it possible, I've written special helper
'adbrunner' (included to CrystaX NDK) which is used as testing.launcher.
It a) take executable with all it's command line arguments, b) tries to distinguish arguments which are actually file names from others,
c) upload executable, needed shared libraries and detected files to Android device and d) run executable on device.

This is the same approach that I took for my QNX on ARM test runner NA-QNX650-SP1-ARM (except compilation is done on QNX x86). I wrote a shell script which gathers the files and transfers them using SSH.

error_handling_test fails on my runner too. The problem is caused by these lines in errors_handling_test.cpp which causes it to try to open a different file than the one from the command line:
@#ifdef LIMITED_TEST@
@pattern_file_name += "2";@
@#endif@

One possible solution would be to pass the names of both files on the command line and choose between @argv[1]@ and @argv[2]@.

As I can see at http://www.boost.org/development/tests/develop/developer/test.html, recent runs of @errors_handling_test@ are fixed, so I close this bug as INVALID.

Also available in: Atom PDF