Project

General

Profile

Actions

Support #909

closed

Problem launching native code debug

Added by Violet Giraffe about 6 years ago. Updated about 6 years ago.

Status:
Duplicated
Priority:
Normal
Category:
-
Target version:
-
Start date:
03/20/2015
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
arm
Host OS:
Windows
Toolchain:
Android version:
4.4 (android-19)
CrystaX Version:

Description

I'm trying to debug native code the same way I did with the official NDK, and gdb crashes. I didn't edit any configs at all, simply replaced the NDK r10 with Crystax 10.1. Is it a known problem? Do I need to edit some settings? I don't know if it's a bug or a user error. Probably the latter, but I couldn't find any instruction on setting up debugging in Eclipse specifically with Crystax NDK.

Actions #1

Updated by Dmitry Moskalchuk about 6 years ago

Violet Giraffe wrote:

I'm trying to debug native code the same way I did with the official NDK, and gdb crashes. I didn't edit any configs at all, simply replaced the NDK r10 with Crystax 10.1. Is it a known problem? Do I need to edit some settings? I don't know if it's a bug or a user error.

No, this is not known error. We need more details to help you. Please explain as detailed as possible what you did and how to reproduce the problem. Minimal project reproducing the bug would be very helpful.

Probably the latter, but I couldn't find any instruction on setting up debugging in Eclipse specifically with Crystax NDK.

There is no anything CrystaX-specific for debugging, which could not be applied to Google's NDK. Shortly speaking, it should work with exactly the same settings as used for Google's NDK.

Actions #2

Updated by Dmitry Moskalchuk about 6 years ago

  • Status changed from Open to Waiting for feedback
  • Assignee set to Dmitry Moskalchuk
  • Priority changed from Low to Normal
Actions #3

Updated by Violet Giraffe about 6 years ago

Here's the project: https://drive.google.com/file/d/0B_uKrE3_LamxeDZ2Ry05ZTBPNjg/view?usp=sharing
It's hello-jni sample from Android NDK with debugging configured. If you place it at C:/Development/hello-jni, you won't have to edit any paths.
I don't know if I set it up entirely correctly (it's always a pain doing that), but gdb definitely should not crash - which it does in this project same as in my actual project I wanted to debug.
I've confirmed that switching back to NDK r10d lets me debug my project no problem.

Actions #4

Updated by Dmitry Moskalchuk about 6 years ago

  • Status changed from Waiting for feedback to In Progress
Actions #5

Updated by Alexander Zhukov about 6 years ago

  • Assignee changed from Dmitry Moskalchuk to Alexander Zhukov
Actions #6

Updated by Alexander Zhukov about 6 years ago

  • Status changed from In Progress to Waiting for feedback

Violet Giraffe wrote:

Here's the project: https://drive.google.com/file/d/0B_uKrE3_LamxeDZ2Ry05ZTBPNjg/view?usp=sharing
It's hello-jni sample from Android NDK with debugging configured.

Thanks, I tried to debug hellojni and it seems to be a known bug in windows version of 10.1.
Could you please try to run gdb from the command line and copy here an output?
Just start cygwin shell window, cd to the HelloJni dir and run from the command:
/ndk-gdb --verbose --force --launch=com.example.hellojni.HelloJni

Actions #7

Updated by Dmitry Moskalchuk about 6 years ago

Alexander Zhukov wrote:

Violet Giraffe wrote:

Here's the project: https://drive.google.com/file/d/0B_uKrE3_LamxeDZ2Ry05ZTBPNjg/view?usp=sharing
It's hello-jni sample from Android NDK with debugging configured.

Thanks, I tried to debug hellojni and it seems to be a known bug in windows version of 10.1.
Could you please try to run gdb from the command line and copy here an output?
Just start cygwin shell window, cd to the HelloJni dir and run from the command:
/ndk-gdb --verbose --force --launch=com.example.hellojni.HelloJni

Alternatively, you could try our "latest nightly build":https://dl.crystax.net/ndk/windows/current/ where we've fixed that problem (and many others) and see if the problem gone. This URL is password-protected, so I'll send credentials to you by e-mail.

Actions #8

Updated by Violet Giraffe about 6 years ago

Thanks, the nightly build did the trick, debugging works!

Actions #9

Updated by Dmitry Moskalchuk about 6 years ago

  • Status changed from Waiting for feedback to Duplicated
  • % Done changed from 0 to 100

Great! Closing as duplicate of #358

Actions

Also available in: Atom PDF