Project

General

Profile

Bug #896

Boost dependencies when using it as a shared library

Added by Alex Afanasyev over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
02/09/2015
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
Host OS:
Mac
Toolchain:
Android version:
CrystaX Version:

Description

I'm trying to use boost as a shared library and got a couple of unexpected things that not sure how to handle properly. More specifically, one of the libraries I'm using is boost_regex (boost_regex_shared). Everything is fine until the point of the deployment. The library itself depends on icu shared libraries, which are not automatically copied to the destination and I'm not sure what is the proper way to handle this copying.

I actually tried to do some tricks with including icu module and adding icu*_shared dependencies. It finally copied things, but then it resulted in unknown symbol error (I will try to reproduce the problem again later).

The only workable workaround I have so far is avoid boost_regex_shared and use boost_regex_static, though I don't like it in the long run.

History

#1 Updated by Dmitry Moskalchuk over 4 years ago

  • Priority changed from Normal to High
  • Target version set to 10.2.0

I actually tried to do some tricks with including icu module and adding icu*_shared dependencies. It finally copied things, but then it resulted in unknown symbol error (I will try to reproduce the problem again later).

Adding @$(call import-module,icu/54.1)@ and then adding specific ICU libraries as dependecy should do the trick. Actually, such dependencies should be noted in Boost Android.mk so it's our miss. Thank you for noting this, we'll fix it. Until that, please specify it in your Android.mk.

Regarding unknown symbol error - please let us know exact text of error. It's abnormal and shouldn't be. We haven't experienced such errors in our tests, so please help us solving it.

#2 Updated by Dmitry Moskalchuk about 4 years ago

  • Assignee set to Dmitry Moskalchuk

#3 Updated by Dmitry Moskalchuk about 4 years ago

  • Status changed from Open to In Progress

#4 Updated by Dmitry Moskalchuk about 4 years ago

  • Status changed from In Progress to Done
  • % Done changed from 0 to 100

#5 Updated by Dmitry Moskalchuk almost 4 years ago

  • Status changed from Done to Closed

Closing this ticket since it was verified that Boost dependencies tests works fine in last nightly builds.

Also available in: Atom PDF