Project

General

Profile

Bug #576

run-tests.sh fails on 32-bit Windows

Added by Dmitry Moskalchuk about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Category:
test
Target version:
Start date:
08/13/2014
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
Host OS:
Windows
Toolchain:
Android version:
CrystaX Version:

Description

COMMAND: C:/cygwin/bin/bash.exe --login -c 'cd /cygdrive/c/tmp/crystax-ndk-ndk/argon.crystax.net-b101/android-ndk-dev && ./tests/run-tests.sh --verbose -j1'

expr: syntax error
expr: syntax error
To follow build in another terminal, please use: tail -F /tmp/ndk-ndk/tests/build-tests.log
Awk script: extract-launchable.awk: passed multiple-categories.in
Awk script: extract-launchable.awk: passed multiple-launchables.in
Awk script: extract-launchable.awk: passed no-launchable.in
Awk script: extract-launchable.awk: passed one-launchable.in
Awk script: extract-pid.awk: passed test-1.in
Awk script: gen-cygwin-deps-converter.awk: passed test-1.in
Awk script: gen-cygwin-deps-converter.awk: passed test-2.in
Awk script: gen-windows-host-path.awk: passed test-1.in
Using release NDK samples from: /cygdrive/c/tmp/crystax-ndk-ndk/argon.crystax.net-b101/android-ndk-dev/samples
Building NDK sample: MoreTeapots

COMMAND: cd /tmp/ndk-ndk/tests/build/MoreTeapots

COMMAND: /cygdrive/c/tmp/crystax-ndk-ndk/argon.crystax.net-b101/android-ndk-dev/ndk-build -j1 -B APP_LDFLAGS= APP_CFLAGS=

TARGET_ARCH_ABI=armeabi-v7a-hard
LOCAL_ARM_MODE=
TARGET_ARCH_ABI=arm64-v8a
LOCAL_ARM_MODE=
TARGET_ARCH_ABI=x86_64
LOCAL_ARM_MODE=
TARGET_ARCH_ABI=mips64
LOCAL_ARM_MODE=
TARGET_ARCH_ABI=armeabi-v7a
LOCAL_ARM_MODE=
TARGET_ARCH_ABI=armeabi
LOCAL_ARM_MODE=
TARGET_ARCH_ABI=x86
LOCAL_ARM_MODE=
TARGET_ARCH_ABI=mips
LOCAL_ARM_MODE=
[armeabi-v7a-hard arm64-v8a x86_64 mips64 armeabi-v7a armeabi x86 mips] Cygwin : Generating dependency file converter script
[armeabi-v7a-hard] Compile++ thumb: MoreTeapotsNativeActivity <= MoreTeapotsNativeActivity.cpp
/bin/sh: /cygdrive/c/tmp/crystax-ndk-ndk/argon.crystax.net-b101/android-ndk-dev/toolchains/arm-linux-androideabi-4.6/prebuilt/windows-/bin/arm-linux-androideabi-g++: No such file or directory

Root cause here is path to arm-linux-androideabi-g++ - it contains "windows-" component in path instead of just "windows" for x86 build

#1

Updated by Alexander Zhukov about 6 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Not a bug, really.
There is no support for perl windows cross builds right now.

#2

Updated by Dmitry Moskalchuk about 6 years ago

  • Status changed from Closed to Open
  • % Done changed from 100 to 0
#3

Updated by Dmitry Moskalchuk about 6 years ago

  • Target version set to 10.0.0
#4

Updated by Alexander Zhukov about 6 years ago

  • Status changed from Open to In Progress
#5

Updated by Alexander Zhukov about 6 years ago

  • Assignee set to Alexander Zhukov
#6

Updated by Alexander Zhukov about 6 years ago

  • Assignee changed from Alexander Zhukov to Dmitry Moskalchuk

We should add some environment variables into environment:

export PROCESSOR_ARCHITECTURE=x86
export PROCESSOR_IDENTIFIER='x86 Family 6 Model 58 Stepping 9, GenuineIntel'
export PROCESSOR_LEVEL=6
export PROCESSOR_REVISION=3a09
export PROGRAMFILES='C:\Program Files'

#7

Updated by Dmitry Moskalchuk about 6 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF