Project

General

Profile

Bug #1189

Black screen in Cocos2d-x application

Added by Vladislav Navrocky almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
12/17/2015
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
arm, x86
Host OS:
Linux
Toolchain:
Android version:
2.3.3 (android-10), 5.0 (android-21)
CrystaX Version:

Description

Cocos2d-x demo application hungs with black screen when i use CrystaX to build. With a standard Google's NDK all goes fine.

This problem appeared on all my android devices with Intel Atom SOC (asus_z008D) and some others arm based devices (Fly IQ245 Plus).

History

#1

Updated by Vladislav Navrocky almost 4 years ago

crystax version 10.2.1

#2

Updated by Dmitry Moskalchuk almost 4 years ago

  • Assignee set to Dmitry Moskalchuk
  • Priority changed from Normal to High
  • Target version set to 10.3.1
#3

Updated by Dmitry Moskalchuk almost 4 years ago

  • CrystaX Version set to 10.2.1
#4

Updated by Dmitry Moskalchuk almost 4 years ago

  • Status changed from Open to Waiting for feedback

Can't reproduce.

Here is what I did to check it:

$ git clone https://github.com/dmcrystax/cocos2d-x.git
...
$ cd cocos2d-x
$ python download-deps.py
...
$ git submodule update --init
...
$ python setup.py
...
$ source ~/.zshrc
$ cocos new MyGame -p net.crystax.mygame -l cpp -d projects/MyGame
...
$ cd projects/MyGame
$ cocos run -p android -j 4 --app-abi armeabi-v7a
...

Having these steps done, I can successfully run cocos2d-x demo on all my devices, running Android 4.4, 5.0, 5.1 and 6.0 (ARM). Have not tried on x86 tablet yet, but will check soon.

Note that I've cloned https://github.com/dmcrystax/cocos2d-x.git instead of https://github.com/cocos2d/cocos2d-x.git. This is my fork, where I've fixed minor compile error, so it differ from official one by just "one commit":https://github.com/dmcrystax/cocos2d-x/commit/bc85f590265bcb2c1369e1e9ca7f011ff6b9b018. I've sent "pull request":https://github.com/cocos2d/cocos2d-x/pull/14727, so it will be merged to official repository soon.

Except of the mentioned compile error, I don't see any problems with cocos2d-x demo being built by CrystaX NDK 10.3.0. If you still experience problems, please provide minimal example how I can reproduce it (having logs from your device would be helpful too).

#5

Updated by Dmitry Moskalchuk over 3 years ago

  • Status changed from Waiting for feedback to Closed
  • % Done changed from 0 to 100

Closing as "not reproducible". If you find this issue again and would be able to provide minimal example, feel free to reopen it.

Also available in: Atom PDF