Project

General

Profile

Actions

Bug #929

closed

__EXCEPTIONS is not defined when building GNU libstdc++

Added by Dmitry Moskalchuk about 6 years ago. Updated about 6 years ago.

Status:
Invalid
Priority:
High
Category:
-
Target version:
-
Start date:
04/24/2015
Due date:
% Done:

0%

Estimated time:
CPU Architecture:
Host OS:
Toolchain:
Android version:
CrystaX Version:

Description

This cause problem with definition of internal macro @ _GLIBCXX_THROW_OR_ABORT@, which call @abort@ instead of throwing @bad_alloc@ in case of problems with memory allocation.

"Here":http://stackoverflow.com/questions/29840660/operator-new-does-not-throw-bad-alloc-on-android are some explanations.

Actions #1

Updated by Dmitry Moskalchuk about 6 years ago

  • Status changed from Open to Invalid
Actions #2

Updated by Dmitry Moskalchuk about 6 years ago

Not a bug. See explanation "here":http://stackoverflow.com/a/29846145/1104932

Actions

Also available in: Atom PDF