Project

General

Profile

Bug #697

Build of tests/build/issue36131-flto-c++11 failed for clang3.4/3.5

Added by Dmitry Moskalchuk over 6 years ago. Updated about 6 years ago.

Status:
Duplicated
Priority:
Low
Assignee:
-
Category:
test
Target version:
-
Start date:
10/03/2014
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
Host OS:
Toolchain:
clang-3.4, clang-3.5
Android version:
CrystaX Version:
#1

Updated by Alexander Zhukov about 6 years ago

  • Assignee changed from Dmitry Moskalchuk to Alexander Zhukov
#2

Updated by Alexander Zhukov about 6 years ago

  • Subject changed from Build of tests/build/issue36131-flto-c++11 failed for clang3.4 to Build of tests/build/issue36131-flto-c++11 failed for clang3.4/3.5
  • Assignee deleted (Alexander Zhukov)
  • Priority changed from Normal to Low
  • Target version deleted (10.0.0)
  • Toolchain clang-3.5 added

Google's NDK r10d shows the same result:
zuav@ithilien$ NDK_TOOLCHAIN_VERSION=clang3.4 ./tests/run-tests.sh --verbose issue36131-flto-c++11 -j1
To follow build in another terminal, please use: tail -F /tmp/ndk-zuav/tests/build-tests.log
Awk script: extract-launchable.awk: passed multiple-categories.in
Awk script: extract-launchable.awk: passed multiple-launchables.in
Awk script: extract-launchable.awk: passed no-launchable.in
Awk script: extract-launchable.awk: passed one-launchable.in
Awk script: extract-pid.awk: passed test-1.in
Awk script: gen-cygwin-deps-converter.awk: passed test-1.in
Awk script: gen-cygwin-deps-converter.awk: passed test-2.in
Awk script: gen-windows-host-path.awk: passed test-1.in
Using release NDK samples from: /opt/android/android-ndk-r10d/samples
Building NDK build test: issue36131-flto-c++11

COMMAND: cd /tmp/ndk-zuav/tests/build/issue36131-flto-c++11

COMMAND: /opt/android/android-ndk-r10d/ndk-build -j1 -B APP_LDFLAGS= APP_CFLAGS=

[armeabi-v7a-hard] Compile++ thumb: issue36131-flto-c++11 <= issue36131-flto-c++11.cxx
clang++: warning: argument unused during compilation: '-Wa,--noexecstack'
[armeabi-v7a-hard] Executable : issue36131-flto-c++11
/opt/android/android-ndk-r10d/toolchains/arm-linux-androideabi-4.8/prebuilt/darwin-x86_64/lib/gcc/arm-linux-androideabi/4.8/../../../../arm-linux-androideabi/bin/ld: error: /opt/android/android-ndk-r10d/toolchains/llvm-3.4/prebuilt/darwin-x86_64/bin/../lib/LLVMgold.dylib: could not load plugin library: dlopen(/opt/android/android-ndk-r10d/toolchains/llvm-3.4/prebuilt/darwin-x86_64/bin/../lib/LLVMgold.dylib, 2): Library not loaded: @executable_path/../lib/libLTO.dylib
Referenced from: /opt/android/android-ndk-r10d/toolchains/llvm-3.4/prebuilt/darwin-x86_64/lib/LLVMgold.dylib
Reason: image not found
/opt/android/android-ndk-r10d/toolchains/arm-linux-androideabi-4.8/prebuilt/darwin-x86_64/lib/gcc/arm-linux-androideabi/4.8/../../../../arm-linux-androideabi/bin/ld: error: ./obj/local/armeabi-v7a-hard/objs/issue36131-flto-c++11/issue36131-flto-c++11.o:1:3: invalid character
/opt/android/android-ndk-r10d/toolchains/arm-linux-androideabi-4.8/prebuilt/darwin-x86_64/lib/gcc/arm-linux-androideabi/4.8/../../../../arm-linux-androideabi/bin/ld: error: ./obj/local/armeabi-v7a-hard/objs/issue36131-flto-c++11/issue36131-flto-c++11.o:1:3: syntax error, unexpected $end
/opt/android/android-ndk-r10d/toolchains/arm-linux-androideabi-4.8/prebuilt/darwin-x86_64/lib/gcc/arm-linux-androideabi/4.8/../../../../arm-linux-androideabi/bin/ld: error: ./obj/local/armeabi-v7a-hard/objs/issue36131-flto-c++11/issue36131-flto-c++11.o: not an object or archive
/opt/android/android-ndk-r10d/platforms/android-3/arch-arm/usr/lib/../lib/crtbegin_dynamic.o:crtbrand.c:function _start: error: undefined reference to 'main'
clang++: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [obj/local/armeabi-v7a-hard/issue36131-flto-c++11] Error 1
!!! BUILD FAILURE [/opt/android/android-ndk-r10d/tests/build/issue36131-flto-c++11]!!! See /tmp/ndk-zuav/tests/build-tests.log for details or use --verbose option!

#3

Updated by Dmitry Moskalchuk about 6 years ago

  • Status changed from Open to Duplicated
  • % Done changed from 0 to 100

Duplicate of #696

Also available in: Atom PDF