Project

General

Profile

Bug #346

Can't load libgnuobjc_shared.co

Added by Dmitry Moskalchuk over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
05/02/2013
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
all
Host OS:
all
Toolchain:
all
Android version:
CrystaX Version:

Description

When Android tries to load the libgnuobjc_shared.so library it fails with:

05-01 09:30:52.505: D/dalvikvm(20438): Trying to load lib /data/data/com.djinnworks.StickStuntBiker2.free/lib/libgnuobjc_shared.so 0x41565be0
05-01 09:30:52.515: E/AndroidRuntime(20438): Caused by: java.lang.UnsatisfiedLinkError: Cannot load library: reloc_library[1286]: 1811 cannot locate '__fpclassifyd'...

__fpclassifyd is available at runtime in the libm.so library, but libgnuobjc_shared.so was not linked against libm at compile time so android doesn't resolve the symbol.

Simple code which load libgnuobjc_shared.so in Android app:

static {
System.loadLibrary("gnuobjc_shared");
}

History

#1

Updated by Alexander Zhukov over 6 years ago

  • Status changed from Open to In Progress
  • % Done changed from 0 to 50
#2

Updated by Alexander Zhukov over 6 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF