Project

General

Profile

Bug #271

Test device/issue22165-typeinfo failed to run

Added by Alexander Zhukov over 6 years ago. Updated almost 5 years ago.

Status:
Duplicated
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
03/13/2013
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
x86
Host OS:
Linux, Mac OS X, Windows
Toolchain:
gcc-4.4.3
Android version:
CrystaX Version:

Description

Sample output:

COMMAND: /opt/android/android-sdk-linux/platform-tools/adb -s emulator-5558 shell chmod 0755 /data/local/tmp/ndk-tests/libissue22165_throwable.so

Running device test [x86]: issue22165-typeinfo (issue22165_main)
/opt/android/android-sdk-linux/platform-tools/adb -s "emulator-5558" shell "cd /data/local/tmp/ndk-tests && LD_LIBRARY_PATH=/data/local/tmp/ndk-tests ./issue22165_main"
call throw_an_exception()
throw_an_exception()
yep! i am in constructor
terminate called after throwing an instance of 'my_exception'
what(): my exception
[1] Segmentation fault LD_LIBRARY_PATH=...
test-return-code:139
---> TEST FAILED!!

History

#1

Updated by Alexander Zhukov over 6 years ago

  • Description updated (diff)
  • CPU Architecture x86 added
  • Host OS Linux added
  • Toolchain gcc-4.4.3 added
#2

Updated by Alexander Zhukov over 6 years ago

  • Host OS Mac OS X added
#3

Updated by Alexander Zhukov over 6 years ago

  • Host OS Windows added
#4

Updated by Dmitry Moskalchuk almost 5 years ago

  • Status changed from Open to Duplicated
  • % Done changed from 0 to 100

Duplicate of #264

Also available in: Atom PDF