Project

General

Profile

Task #168

Add NDK_SUPPRESS_WARNINGS variable to ndk-build

Added by Dmitry Moskalchuk over 7 years ago. Updated over 7 years ago.

Status:
Invalid
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
01/19/2013
Due date:
% Done:

0%

Estimated time:
CPU Architecture:
Host OS:
Toolchain:
Android version:

Description

This is needed because warnings produced by ndk-build recognized as errors when build from eclipse and, therefore, eclipse can't continue.
Example of warning:

/opt/android/android-ndk-r8d/build/core/add-application.mk:128: Android NDK: WARNING: APP_PLATFORM android-9 is larger than android:minSdkVersion 8 in /Volumes/DARWIN-SSD/work/joybits/ipad/of_ipad_new/apps/DoodleGod/DoodleAnything-1.5-HD/android/DoodleEverything/AndroidManifest.xml

Suggested fix should behave like that finally:

ndk-build NDK_SUPPRESS_WARNINGS=1

#1

Updated by Dmitry Moskalchuk over 7 years ago

  • Subject changed from Add NDK_SUPPRESS_WARNING variable to ndk-build to Add NDK_SUPPRESS_WARNINGS variable to ndk-build
#2

Updated by Dmitry Moskalchuk over 7 years ago

  • Description updated (diff)
#3

Updated by Dmitry Moskalchuk over 7 years ago

  • Status changed from Open to Invalid

After some investigation it looks like adding such flag would be a bad idea so reject this task

Also available in: Atom PDF