Project

General

Profile

Bug #1262

[objc] Tests starts failing after switch libobjc2 to upstream CMake-based build approach

Added by Dmitry Moskalchuk over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Category:
libobjc2
Target version:
Start date:
02/11/2016
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
Host OS:
OS X
Toolchain:
clang-3.6, clang-3.7
Android version:
CrystaX Version:

Description

2016-02-11 10:57:53.311 UTC: BEG device test [crystax-issue995-objective-c-literals] clang3.7 +PIE: armeabi-v7a
2016-02-11 10:57:53.312 UTC: ## COMMAND: ruby /tmp/crystaxndk-ndk/crystax-ndk-10.3.1-b805-darwin-x86_64/tools/adbrunner --verbose --keep-going --no-print-timestamps --adb=/tmp/adb/adb --ndk=/tmp/crystaxndk-ndk/crystax-ndk-10.3.1-b805-darwin-x86_64 --abi=armeabi-v7a --timeout=180 --emulator-tag=ab73511a-11f8-4c2b-a179-773effa8f918 --device-path=/data/local/tmp/ndk-tests --run-on-all-devices --pie --mro-prefix=CRYSTAX-MRO-03b7839afa864ea9935d019882bcfa32 --symbols-directories=/tmp/crystaxndk-ndk/crystax-ndk-10.3.1-b805-darwin-x86_64/sources/crystax/libs/armeabi-v7a,/tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/obj/local/armeabi-v7a --ld-library-path=/tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/libs/armeabi-v7a @/tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/executables-armeabi-v7a.txt
2016-02-11 10:57:53.312 UTC: ## CWD: /Users/ndk
2016-02-11 10:57:53.452 UTC:    > ## ADBRUNNER.50994 ## COMMAND: /tmp/adb/adb -s emulator-5554 shell getprop ; echo EXITCODE95ff4992b9924c02a3fdfe0c2c6cc2c5:$?
2016-02-11 10:57:53.625 UTC:    > ## ADBRUNNER.50994 ## COMMAND: /tmp/adb/adb -s emulator-5556 shell getprop ; echo EXITCODE27b856438fbc4f41a965a3a56f33ec93:$?
2016-02-11 10:57:53.806 UTC:    > ## ADBRUNNER.50994 EXEC: /tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/libs/armeabi-v7a/test-objc-literals
2016-02-11 10:57:53.807 UTC: RUN device test [crystax-issue995-objective-c-literals] clang3.7 +PIE: armeabi-v7a [1/1] android-19 'emulator-5554'
2016-02-11 10:57:53.807 UTC:    > ## ADBRUNNER.50994 [emulator-5554] LOCK  (attempt #1): /tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/libs/armeabi-v7a/test-objc-literals
2016-02-11 10:57:53.807 UTC:    > ## ADBRUNNER.50994 [emulator-5554] START (attempt #1): /tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/libs/armeabi-v7a/test-objc-literals
2016-02-11 10:57:53.808 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  mkdir -p /data/local/tmp/ndk-tests/armeabi-v7a/tmp && mkdir -p /data/local/tmp/ndk-tests/armeabi-v7a/lib && mkdir -p /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2 && mkdir -p /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2/bin && mkdir -p /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2/data
2016-02-11 10:57:54.067 UTC:    > ## ADBRUNNER.50994 [emulator-5554] COPY: /tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/libs/armeabi-v7a/test-objc-literals -> /Users/ndk/.crystax/adbrunner/stripped/armeabi-v7a/test-objc-literals.4fd4b620bf13cb03bd6a4ec37dc6722adf758ed249ed017ca4c1bca3d32a562a
2016-02-11 10:57:54.067 UTC:    > ## ADBRUNNER.50994 [emulator-5554] STRIP: /Users/ndk/.crystax/adbrunner/stripped/armeabi-v7a/test-objc-literals.4fd4b620bf13cb03bd6a4ec37dc6722adf758ed249ed017ca4c1bca3d32a562a
2016-02-11 10:57:54.074 UTC:    > ## ADBRUNNER.50994 [emulator-5554] PUSH: /Users/ndk/.crystax/adbrunner/stripped/armeabi-v7a/test-objc-literals.4fd4b620bf13cb03bd6a4ec37dc6722adf758ed249ed017ca4c1bca3d32a562a -> /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2/bin/exe28978631c1444ccc82016262888db8c6
2016-02-11 10:57:54.113 UTC:    > ## ADBRUNNER.50994 [emulator-5554] 1520 KB/s (23468 bytes in 0.015s)
2016-02-11 10:57:54.115 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  chmod 0755 /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2/bin/exe28978631c1444ccc82016262888db8c6
2016-02-11 10:57:54.222 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 294fb993a214e332ccecb192e3098aea8d4b7a85aef06a6c66027fdb41eb84d0 /data/local/tmp/ndk-tests/armeabi-v7a/lib/libcrystax.so.sha256 2>/dev/null
2016-02-11 10:57:54.522 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 21a2c3ff105d74ac3ea8159796913385ad8c800bf0914f0806307bac5b6b08af /data/local/tmp/ndk-tests/armeabi-v7a/lib/libobjc.so.sha256 2>/dev/null
2016-02-11 10:57:54.753 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 5332c9cad33cf76adc045ae268b362f901d0089209e30e15df366bbfa38429cb /data/local/tmp/ndk-tests/armeabi-v7a/lib/libCFNetwork.so.sha256 2>/dev/null
2016-02-11 10:57:54.867 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x ce132ea17410f34cd67ef94f1734696128429f59bf5d389a5311cb0aa8dceaea /data/local/tmp/ndk-tests/armeabi-v7a/lib/libCoreData.so.sha256 2>/dev/null
2016-02-11 10:57:54.986 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 007fafd9e5ee40940234e76deeffd14aa2a9b04f42aa3edfe76b0e1b5a477b19 /data/local/tmp/ndk-tests/armeabi-v7a/lib/libCoreFoundation.so.sha256 2>/dev/null
2016-02-11 10:57:55.100 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 8d011574cfa54a6de7c19c7ea0e4f1b6cd5c8a550c1a3ba7cc48d6ae77eaec37 /data/local/tmp/ndk-tests/armeabi-v7a/lib/libCoreGraphics.so.sha256 2>/dev/null
2016-02-11 10:57:55.211 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 03f962b533ea31be02932c5b0ccb7be050299229e476cf68d972f20ec80afefb /data/local/tmp/ndk-tests/armeabi-v7a/lib/libCoreServices.so.sha256 2>/dev/null
2016-02-11 10:57:55.341 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 826009a7a5997d73f35902e01a0bac27a1f1be0135afa54acab9faa7b5958df1 /data/local/tmp/ndk-tests/armeabi-v7a/lib/libCoreText.so.sha256 2>/dev/null
2016-02-11 10:57:55.461 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x 8573fc236c63deab724320234dabee90127164e36ce3f94489ceca8fda735508 /data/local/tmp/ndk-tests/armeabi-v7a/lib/libCoreVideo.so.sha256 2>/dev/null
2016-02-11 10:57:55.559 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  grep -q -x d7791bc7e3db9715aadb9caaf05a0723942ae400f41abf81dc1161c1ada992d9 /data/local/tmp/ndk-tests/armeabi-v7a/lib/libFoundation.so.sha256 2>/dev/null
2016-02-11 10:57:55.678 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN:  log LOGCAT-TAG-d955b24f77f54f0884578610fbcd6925 && cd /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2/bin && LD_LIBRARY_PATH=/data/local/tmp/ndk-tests/armeabi-v7a/lib TMPDIR=/data/local/tmp/ndk-tests/armeabi-v7a/tmp ./exe28978631c1444ccc82016262888db8c6 
2016-02-11 10:57:55.801 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    > CANNOT LINK EXECUTABLE: could not load library "libFoundation.so" needed by "./exe28978631c1444ccc82016262888db8c6"; caused by could not load library "libCoreData.so" needed by "libFoundation.so"; caused by could not load library "libCoreFoundation.so" needed by "libCoreData.so"; caused by could not load library "libCoreServices.so" needed by "libCoreFoundation.so"; caused by could not load library "libobjc.so.4.6" needed by "libCoreServices.so"; caused by library "libobjc.so.4.6" not found
2016-02-11 10:57:55.814 UTC:    > ## ADBRUNNER.50994 [emulator-5554] RUN [$?=1]: log LOGCAT-TAG-d955b24f77f54f0884578610fbcd6925 && cd /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2/bin && LD_LIBRARY_PATH=/data/local/tmp/ndk-tests/armeabi-v7a/lib TMPDIR=/data/local/tmp/ndk-tests/armeabi-v7a/tmp ./exe28978631c1444ccc82016262888db8c6 
2016-02-11 10:57:55.814 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * 
2016-02-11 10:57:55.814 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * 
2016-02-11 10:57:55.815 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * === BEGIN OF ENVIRONMENT ===
2016-02-11 10:57:55.815 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * CMD: /tmp/ndk-tests-macosx10.8/clang3.7/device/crystax-issue995-objective-c-literals/target+PIE/libs/armeabi-v7a/test-objc-literals 
2016-02-11 10:57:55.815 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * PWD: /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2/bin
2016-02-11 10:57:55.815 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * NDK: /tmp/crystaxndk-ndk/crystax-ndk-10.3.1-b805-darwin-x86_64 - CrystaX NDK v10.3.1 (64-bit)
2016-02-11 10:57:55.816 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * === END OF ENVIRONMENT ===
2016-02-11 10:57:57.845 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * 
2016-02-11 10:57:57.845 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * === BEGIN OF LOGCAT ===
2016-02-11 10:57:57.846 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * === END OF LOGCAT ===
2016-02-11 10:57:57.875 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * 
2016-02-11 10:57:57.876 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * === BEGIN OF NDK-STACK ===
2016-02-11 10:57:57.878 UTC:    > ## ADBRUNNER.50994 [emulator-5554]    * === END OF NDK-STACK ===
2016-02-11 10:57:57.881 UTC:    > ## ADBRUNNER.50994 [emulator-5554] ## COMMAND: /tmp/adb/adb -s emulator-5554 shell rm -r /data/local/tmp/ndk-tests/armeabi-v7a/2f7eba57-31ee-449b-9b61-0db9fe91e2c2
2016-02-11 10:57:57.949 UTC:    > ## ADBRUNNER.50994 [emulator-5554] EXIT: 1 (took 0:00:04 on 'emulator-5554')
2016-02-11 10:57:57.949 UTC:    ---> FAILURE: TARGET TEST  [crystax-issue995-objective-c-literals] "test-objc-literals": $?=1
2016-02-11 10:57:57.968 UTC: ERROR: Test crystax-issue995-objective-c-literals failed

Related issues

Blocked by CrystaX NDK - Bug #1352: [darwin] GNUstep libobjc2 is built with SONAME "libobjc.so.4.6"Closed04/01/2016

Actions

History

#1

Updated by Dmitry Moskalchuk over 3 years ago

  • Status changed from Open to In Progress
#3

Updated by Dmitry Moskalchuk over 3 years ago

  • Description updated (diff)
#4

Updated by Dmitry Moskalchuk over 3 years ago

  • Blocked by Bug #1352: [darwin] GNUstep libobjc2 is built with SONAME "libobjc.so.4.6" added
#5

Updated by Dmitry Moskalchuk over 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF