Project

General

Profile

Bug #1197

Boost's Android.mk can't detect correct libraries path if NDK_TOOLCHAIN_VERSION is not specified

Added by Dmitry Moskalchuk over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Category:
boost
Target version:
Start date:
01/02/2016
Due date:
% Done:

100%

Estimated time:
CPU Architecture:
Host OS:
Toolchain:
Android version:
CrystaX Version:

Description

$ $NDK/ndk-build -B V=1
Android NDK: ERROR:$NDK/sources/boost/1.59.0/Android.mk:boost_atomic_static: LOCAL_SRC_FILES points to a missing file
Android NDK: Check that $NDK/sources/boost/1.59.0/libs/arm64-v8a/gnu-/libboost_atomic.a exists or that its path is correct
$NDK/build/core/prebuilt-library.mk:45: *** Android NDK: Aborting . Stop.


Related issues

Is duplicate of CrystaX NDK - Bug #1235: By default `NDK_TOOLCHAIN_VERSION` is not setDuplicated01/21/2016

Actions

History

#1

Updated by Dmitry Moskalchuk over 3 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100
#2

Updated by Dmitry Moskalchuk over 3 years ago

  • Is duplicate of Bug #1235: By default `NDK_TOOLCHAIN_VERSION` is not set added
#3

Updated by Dmitry Moskalchuk over 3 years ago

  • Target version changed from 11.0.0 to 46
#4

Updated by Dmitry Moskalchuk over 3 years ago

  • Target version changed from 46 to 11.0.0

Also available in: Atom PDF